Degraded Performance
Incident Report for Cherwell Software
Resolved
Our Investigations have pointed to our Web Application Firewall provider as being the source of today’s degraded performance. Our provider has implemented a workaround that has demonstrated improved experience for our customers. Teams are continuing to pursue the root cause. We will provide an RCA as one becomes available. If you continue to experience issues please do not hesitate to contact Support. The RCA will be issued in due course.
Posted May 06, 2020 - 14:01 MDT
Update
We are continuing to monitor for any further issues.
Posted May 06, 2020 - 14:00 MDT
Monitoring
Our Investigations have pointed to our Web Application Firewall provider as being the source of today’s degraded performance. Our provider has implemented a workaround that has demonstrated improved experience for our customers. Teams are continuing to pursue the root cause. We will provide an RCA as one becomes available. If you continue to experience issues please do not hesitate to contact Support.
Posted May 06, 2020 - 11:59 MDT
Identified
Our Investigations have pointed to our Web Application Firewall provider as being the source of today’s degraded performance. Our provider has implemented a workaround that has demonstrated improved experience for our customers. Teams are continuing to pursue the root cause. We will provide an RCA as one becomes available we will provide the report upon request. If you continue to experience issues please do not hesitate to contact Support.
Posted May 06, 2020 - 11:48 MDT
Update
We are continuing to investigate this issue.
Posted May 06, 2020 - 11:48 MDT
Update
We are continuing to investigate this issue.
Posted May 06, 2020 - 10:40 MDT
Update
We are continuing to investigate this issue.
Posted May 06, 2020 - 08:51 MDT
Update
The issue is not isolated to AMS, we are investigating issues from different sectors at this time
Posted May 06, 2020 - 08:49 MDT
Investigating
We are currently experiencing degraded performance in the Amazon East Region. The investigation is underway.
Posted May 06, 2020 - 07:46 MDT
This incident affected: US AMS.