Cherwell Self Service Portal - Authentication Issue
Incident Report for Cherwell Software
Resolved
We have resolved the authentication issue for the Cherwell Support Portal, it is available for logging at this time.
Posted Dec 11, 2020 - 08:54 MST
Investigating
We are aware of the issues with authentication to the Cherwell Support Portal. We have identified causation and are working to resolve.
Posted Dec 11, 2020 - 08:40 MST
This incident affected: Cherwell Self Service Portal.