North American Support Line Issue +1.888.826.2288
Incident Report for Cherwell Software
Resolved
This incident has been resolved.
Posted Aug 03, 2020 - 11:56 MDT
Investigating
There are intermittent our North American Support Number, +1.888.826.2288. We are currently working with our provider to resolve this. The issue with connecting successfully to the number is intermittent.
Posted Aug 03, 2020 - 10:28 MDT
This incident affected: Cherwell Self Service Portal.