Cherwell Self Service Portal Down for Maintenance
Incident Report for Cherwell Software
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 01:23 MST
Update
We are continuing to investigate this issue.
Posted Jan 17, 2020 - 01:23 MST
Investigating
We are performing maintenance on self service at this time
Posted Jan 16, 2020 - 13:29 MST
This incident affected: Cherwell Self Service Portal.