London Data Center Connection Issues
Incident Report for Cherwell Software
Resolved
This issue has been resolved
Posted Feb 18, 2020 - 03:32 MST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2020 - 10:49 MST
Update
We are continuing to investigate this issue.
Posted Feb 17, 2020 - 10:13 MST
Investigating
We are currently investigating this issue.
Posted Feb 17, 2020 - 10:12 MST
This incident affected: EMEA Datacenter.